CTV证券资讯网

您现在的位置是:首页 > 外汇

外汇

通达信RSI划线指标公式

2020-08-01 18:02外汇2
{N1:2,120,5;N2:2,250,10;N3:2,500,20;}{参数:P:1,20,3;}{支撑压力线的周期参数P可调}STICKLINE(C>0,0,30,10,0),COLOR353535;STICKLINE(C>0,30,50,10,0),COLOR454545;STICKLINE

{N1:2,120,5;N2:2,250,10;N3:2,500,20;}
{参数:P:1,20,3;}{支撑压力线的周期参数 P可调}
STICKLINE(C>0,0,30,10,0),COLOR353535;
STICKLINE(C>0,30,50,10,0),COLOR454545;
STICKLINE(C>0,50,80,10,0),COLOR555555;
STICKLINE(C>0,80,95,10,0),COLOR757575;
强弱线:50,LINETHICK2,COLOR858585;
警示线:80,POINTDOT,COLORCYAN;
减仓线:90,COLOR00AA55,LINETHICK2;
清仓线:95,COLOR0000AA,LINETHICK2;
LC:=REF(CLOSE,1);
{股旁网-股票公式网站 www.gupang.com}
RSI5:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,NODRAW,COLORFFAAFF;
RSI10:SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100,NODRAW,COLORDDAADD;
RSI20:SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100,NODRAW,COLORAA99AA;
DRAWBAND(RSI5,RGB(195,125,195),RSI10,RGB(0,130,50));
DRAWBAND(RSI10,RGB(165,95,165),RSI20,RGB(0,100,20));
{金叉死叉}
金叉:CROSS(RSI5,RSI20) AND CROSS(RSI10,RSI20),COLORRED,NODRAW;
DRAWTEXT(金叉,RSI5,'←'),COLORRED;
死叉:CROSS(RSI20,RSI10) AND CROSS(RSI20,RSI5),COLORGREEN,NODRAW;
DRAWTEXT(死叉,RSI5,'←'),COLORGREEN;
{RSI顶底背离}
RS:=BARSLAST(REF(CROSS(RSI20,RSI5),1));
RS1:=REF(CLOSE,RS+1)RSI5 AND CROSS(RSI20,RSI5);
顶背离:IF(RS1,RSI5,DRAWNULL),CIRCLEDOT,COLORFFCC00;
STICKLINE(RS1,RSI5,RSI5*0.9,0,0),COLORFFCC00;
DRAWTEXT(RS1,RSI5*0.9,'顶背离'),COLORFFCC00;
S1:=BARSLAST(REF(CROSS(RSI5,RSI20),1));
S1A:=REF(CLOSE,S1+1)>CLOSE AND RSI5>REF(RSI5,S1+1) AND
CROSS(RSI5,RSI20);
底背离:IF(S1A,RSI5,DRAWNULL),CIRCLEDOT,COLOR6699FF;
STICKLINE(S1A,RSI5,RSI5*1.1,0,0),COLOR6699FF;
DRAWTEXT(S1A,RSI5*1.1,'底背离'),COLOR6699FF;
{RSI划线}
OB:=RSI5;
A1:=REF(OB,P)=HHV(OB,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(OB,P)=LLV(OB,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
压力线:DRAWLINE(D1,OB,S11,OB,1),LINETHICK1,COLORCC33CC;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
支撑线:DRAWLINE(D2,OB,U11,OB,1),COLOR00CCCC;
DRAWTEXT(CURRBARSCOUNT=30,25,'强弱用来看趋势 背离用来看顶底'),COLORCC99FF;
DRAWTEXT(CURRBARSCOUNT=30,15,'支撑压力辨起落 设定周期参数 P'),COLORCC99FF;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!

如若转载,请注明出处:https://www.cctvstock.com/waihui/5378fe823f69f95e283f33b0.html

相关资讯

  • KDJ指标的D线分析

    KDJ指标的D线分析

    2020-08-13 15:021

    TCL集团(000100)-KDJ的D线分析图1所示为TCL集团在2009年9月至2010年1月的走势。图1中的浪1、浪2、浪3、浪4和浪5为一个完整的五浪。其中,浪3的涨幅最大,浪4的回调幅度最大,且观察浪3和浪4之后,我们认为浪5将走出一轮比较可观的行情。通过对图1的观察,我们在浪4回调的末端发

  • 大智慧资金流动曲线指标公式推荐

    大智慧资金流动曲线指标公式推荐

    2020-08-13 14:021

    VAR1:=AMOUNT/VOL/100;VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;金额:SUM(AMOUNT,34)/VAR1/100,LINETHICK0,Color9999FF;VAR4:=DMA(VAR2,VOL/金额);VAR5:=100*(C-VAR4)/VAR

  • 短线选股要领—技术指标

    短线选股要领—技术指标

    2020-08-13 13:031

    短线选股要领技术指标股票市场技术指标很多,它们各有侧重,不可能面面俱到,只需熟悉其中几种便可。常用的技术指标有KDJ、RSI等。一般而言,K值在低位(20%左右)2次上穿D值时,是较佳的买入时机;在高位(80%以上)2次下穿D值时,形成死叉,是较佳的卖出时机。RSI指标在0-20时,股票处于超卖,可

  • 通达信凹口平衡线主图指标公式推荐

    通达信凹口平衡线主图指标公式推荐

    2020-08-13 12:010

    百分比:=5;ZIG(3,百分比);{此行可省};波峰距离:PEAKBARS(3,百分比,1),NODRAW;波谷值:=TROUGH(2,百分比,1);波谷距离:=TROUGHBARS(2,百分比,1);距离:=CURRBARSCOUNT,NODRAW;C2:=REF(C,1);比前跌率:=(C2-

  • 如何使用DMI指标?怎么用DMI指标?

    如何使用DMI指标?怎么用DMI指标?

    2020-08-13 11:010

    如何使用DMI指标?怎么用DMI指标?第一,当DMI指标中ADX的数值低于+DI的数值时,特别是低于20以下时,所有的指标显示的买入卖出信号都是无效信号。此外ADXR的数值介于20-25之间时,也应停用任何一种指标。因此,当使用各类指标前,先用DMI趋向指标对股价的运行趋势进行判断是非常必要的一个环

  • 大智慧王者通道主图指标公式

    大智慧王者通道主图指标公式

    2020-08-13 10:331

    股窜网股票公式下载(www.gucuan.com)提示,您正在下载的是:大智慧王者通道主图指标公式M:=33;EMA10:MA(C,10),COLORBLUE,LINETHICK2;TY:=DYNAINFO(8)0;GG:=V=LLV(V,100)ANDTY;DRAWICON(GG,LOW*0.96